Liamngls

Quién sabe qué, cuándo, cómo, dónde y por qué

Archivo para la 'Linux' Categoría...

Guardado en Informática, Linux

Desde que abandoné Ubuntu hace como año y medio casi había olvidado lo que era romper algo en el sistema, algo bastante común hasta esa fecha y de hecho si algo aprendí con la distro de Canonical fué, aparte de a romper el sistema, a instalar, formatear y esas cosillas que por momentos pueden ser bastante desagradables por la pérdida de datos que puede suponer.

Ayer por la tarde tuve una visita inesperada y la imperiosa necesidad de desconectar el portátil de la red para quitarlo de en medio, una de esas cosas que puedes hacer sin que pase nada o que se joda todo ya que alguna vez se ha ido la luz y todo ha seguido funcionando con normalidad al volver a encender el equipo. Pero no todos los días son fiesta así que la secuencia fué tal cual, en principio no tendría por que haber desconectado el portátil de la corriente así que solo cerré la tapa pero luego cuando tuve que hacerlo no tuve tiempo de ponerle la batería, con lo cual simplemente lo desconecté de la corriente.

(más…)

Comentarios (4) Escrito por on Domingo, enero 27th, 2013

Guardado en Linux, Opinión, Software Libre

Pues ya se ha liado parda con el anuncio oficial de Debian de que para la próxima versión, Wheezy, llevará Xfce como entorno de escritorio por defecto abandonando de este modo a Gnome.

La razón que parece bastante lógica es que Gnome pesa demasiado. Pero no es menos cierto que es una excusa bastante cogida por los pelos para cambiar un proyecto por otro. (más…)

Comentarios (7) Escrito por on Sábado, agosto 18th, 2012

Guardado en Informática, Linux, Software Libre

Logo Debian No soy un gran fan del navegador de Google aunque lo uso como segunda opción en Windows mientras que en Debian uso Chromium. Y lo uso casi en exclusiva para Facebook ya que Firefox/Iceweasel y la red social no se llevan muy bien (por supuesto hablo de mi experiencia, no de un problema generalizado).

Pues la cosa es que de un día para otro Facebook dejó de funcionar en Chromium, cargando solo la barra de herramientas (por así decirlo) done está el logo, las notificaciones, etc … y no respondiendo de ningún modo, ni al pinchar en alguna de las pocas opciones visibles ni para cerrar sesión, ni tan siquiera abriendo desde el historial alguna de las aplicaciones. Un problema que achaqué al javascript (ajax o lo que sea), como si el motor estuviese parado invalidando los enlaces … bueno, no sé explicarlo, pero no funcionaba que es lo importante del asunto. (más…)

Comentarios (1) Escrito por on Jueves, abril 5th, 2012

Guardado en Internet, Linux, MAC, Software Libre, Windows

irssi es un cliente IRC que se ejecuta en el terminal, con versiones para Unix/Linux, MAC OS y Windows y liberado bajo licencia GPL. Es altamente configurable mediante temas y scripts y aparte de ser multiplataforma también es multiprotocolo ya que puede conectarse a redes XMPP o MSN o leer correo electrónico con el script adecuado.

Podemos instalar irssi desde el terminal, descargándolo de su sitio web o desde Synaptic (yo he usado esta última opción), los usuarios de Arch Linux pueden instalarlo desde los repositorios con pacman, para el resto de sistemas cada cual el que le toque, en Windows por ejemplo está disponible el instalador típico de toda la vida. (más…)

Comentarios (6) Escrito por on Domingo, marzo 4th, 2012

Guardado en Linux

Bueno, igual van a ser demasiadas preguntas pero el error, al menos en mi caso, es un clasicazo. Lo más curioso es que hasta ahora jamás lo había solucionado de forma directa y ya tenía hasta curiosidad por hacerlo. Para entender que son las claves GPG y su funcionamiento nada como la documentación oficial.

De una forma básica diríamos que las claves GPG sirven para asegurar la comunicación entre dos usuarios, por ejemplo con correos electrónicos cifrados. Pero en nuestro caso la comunicación se hace de cara a firmar un programa y autentificarlo de cara al usuario para su instalación o actualización y cuando las claves no funcionan pueden ser varios los motivos, desde una caida en el servidor, una mala conexión que no permita validar la firma o que la firma ha cambiado y necesitamos actualizarla.

En mi caso concreto de las dos firmas que me daban error una de ellas era la correspondiente al multimedia y en la mitad de los sitios que he visitado y que indicaban como solucionar el error el problema lo tenían con esta misma clave, incluso siendo de un par de años atrás, con lo cual la clave no parece haber cambiado ni tener fecha de caducidad pero por alguna extraña razón simplemente tira el error y toca cargarla de nuevo.

Cuando estemos actualizando los repositorios en busca de actualizaciones, sea a través de Synaptic o Update Manager (Gestor de Actualizaciones) y nos dé el error lo que haremos será copiar la clave (o claves), de este tipo:

07DC563D1F41B907

Y si no siempre podemos hacer un apt-get update en el terminal y copiarlas ahí. A continuación desde el terminal escribiremos lo siguiente cambiando la clave por la que necesitemos actualizar.

gpg --keyserver pgpkeys.mit.edu --recv-key 07DC563D1F41B907 && gpg -a --export 07DC563D1F41B907 | sudo apt-key add -

Y nos mostrará la siguiente salida (si todo ha ido bien, que debería ser que sí).

gpg: solicitando clave 1F41B907 de hkp servidor pgpkeys.mit.edu
gpg: clave 1F41B907: clave pública “Christian Marillat ” importada
gpg: no se encuentran claves absolutamente fiables
gpg: Cantidad total procesada: 1
gpg: importadas: 1
OK

Repetiremos el paso con todas las claves que necesitemos actualizar. Cuando terminemos actualizamos los repositorios desde el terminal o una de las aplicaciones gráficas y listo. Eso es todo, de momento.

Fuente: €quimantux.

Entradas relacionadas

Comentarios (1) Escrito por on Domingo, febrero 19th, 2012

Guardado en Linux, Software Libre

Iceweasel es el navegador por defecto instalado en Debian (con permiso de Epiphany), éste como casi todo el mundo sabrá y si no deberían de saberlo está basado en Firefox así que en la teoría (y en mucha de la práctica) es más o menos lo mismo. El problema aquí es que por defecto la versión instalada de Iceweasel es la 3.5.16 y ya en la mitad del internet da como navegador viejuno y/u obsoleto, de hecho a Google+ ni te deja entrar. Así que vamos a ver unos cómodos y sencillos pasos para poder actualizar a una versión más moderna, a día de ayer (13/01/2012) se instaló la 9.0.1 (más…)

Comentarios (1) Escrito por on Sábado, enero 14th, 2012

Guardado en Informática, Linux

O dicho de otro modo, ahora ha evolucionado a Debian con motivo de de la última actualización a Oneiric Ocelot. Y bueno, no es que sea tan feo pero lo cierto es que Ubuntu tiene un aspecto mucho más bonito en el momento de la instalación.

El pasado Viernes salió el aviso de que estaba disponible la nueva versión así que fui a actualizar desde consola y todo iba estupendamente, hasta que (creo) se actualizó el network manager,  como de costumbre, y se perdió la conexión, ese fué como se suele decir, el principio del fin.

Lo raro del tema es que solo tenía algunos problemillas de dependencias no satisfechas y alguna cosilla que se quedó sin actualizar pero luego usando la opción de reparar paquetes en el modo recovery parecía estar todo bien, todo bien menos mi usuario. Lo cual me tocó un poco las narices porque todos los usuarios estaban bien menos el habitual e incluso podía entrar como root así que finalmente como root salvé todo lo que tenía que salvar en un disco externo y a otra cosa. (más…)

Comentarios (5) Escrito por on Miércoles, octubre 19th, 2011

Guardado en Linux

Puede resultar irónico estar escribiendo esto desde Windows XP, pero bueno, nadie es perfecto y tampoco estoy ahora mismo en mi ordenador.

Hace poco más de mes y medio que tengo instalado de nuevo Ubuntu, concretamente la 11.04 de la cual puedo decir que estoy bastante contento, igual también influye el hecho de que llevaba dos años sin una versión de Ubuntu instalada así que ha sido poco más o menos lo mismo que empezar de nuevo, no he sufrido el cambio a Unity porque simplemente no tenía una versión anterior instalada. (más…)

Comentarios (4) Escrito por on Domingo, junio 26th, 2011

Guardado en Informática, Linux

Hoy es el día que ya se puede descargar la última versión de Ubuntu, la 9.10 con el nombre en clave Karmic Koala, tal como se puede ver en el anuncio lateral que aún mantendré algunos días.

Como esta es una de esas cosas de las que habla todo el mundo y yo no quiero ser cansino con el tema os dejo un enlace seleccionado al azar de entre mis feeds para ver las novedades que incorpora esta nueva versión (algunas de ellas, claro) y los procedimientos para actualizar o instalar desde cero.

A donde yo quería llegar es que tengo ganas de probarla, aunque posiblemente no lo haga hasta el fin de semana o principios de la semana que viene para ver si han metido los paquetes para el modem Alcatel X060 de Symio, lo cual sería un puntazo.

Entradas relacionadas

Comentarios (15) Escrito por on Jueves, octubre 29th, 2009

Guardado en Linux, Webmaster

Una de las cosas que se pueden hacer desde Synaptic y que quizás haya gente que no lo sepa es instalar determinados paquetes para una tarea común de forma automágica más allá del mítico apt-get install paquete paquete paquete; ya que aunque todos sabemos que el sistema nos instalará las dependencias necesarias para que todo funcione es posible que nos falte alguna librería que no se llegue a instalar y luego lo que sea que hayamos instalado no funcione bien o, simplemente, no funcione.

Abrimos el Gestor de Paquetes Synaptic desde el menú de Admistración y pinchamos en Editar – Marcar paquetes por tarea…, luego seleccionamos lo que queremos instalar, la marcamos y aplicamos … lo de siempre.

En Ubuntu, por ejemplo, se pueden instalar, entre otras cosas:

  • LAMP (Linux, Apache, MySQL, PHP)
  • Paquetes de audio de Ubuntu Studio
  • Paquetes de vídeo de Ubuntu Studio
  • Servidor DNS
  • Servidor de correo
  • Servidor OpenSSH

En Debian, por poner otro ejemplo, LAMP sale como Web Server y en ambos casos (e imagino que cualquier otra distro que use Synaptic) después de instalar los paquetes para correr un servidor web en el equipo habría que instalar por separado phpmyadmin.

En Tecnologías Libres está explicado con capturas de pantalla de todo el proceso, que yo no las he hecho porque maté a Ubuntu y en Debian me ha dado pereza de instalar un capturador de pantalla (Ksnapshot porque el que va por defecto es una castaña) y aunque la entrada se centra en LAMP obviamente es aplicable a cualquier otra tarea que queramos instalar.

Comentarios (0) Escrito por on Viernes, noviembre 28th, 2008